nTop Platform 2.06 - What's New

Follow

Summary

nTopology’s nTop Platform 2.6 is here! This release features significant updates to our section cut tool, which now lets users cut through multiple objects at once. We’ve also introduced new menus for account settings, support, and software updates. The new software update menu also includes a progress bar to track the download of the latest release. In addition, local licenses are now hosted on app.ntopology.com. nTopology’s dedicated support team is ready to help answer any questions you may have about this new release.

New Features and Improvements

Topology Optimization Objective and Constraint Graphs

  • Topology Optimization results now include graphs for all objectives and constraints in the Display tab.
  • To access the Display tab, select the question mark icon at the top right of the Topology Optimization block to open the information panel. Once open, select the Display tab and select the objective or constraint graph you’d like to see.

TopOpGraphs.png

Toolkits now ship with nTop Platform

  • The following Toolkits now ship with nTop Platform:
    • Additive Manufacturing
    • Architected Materials
    • Design Analysis
    • Lightweighting
    • Topology Optimization
  • There is no additional installation process required.
  • The toolkits installer, which was originally hosted on user accounts at app.ntopology.com has been removed.
  • All toolkit example files are hosted on user accounts at app.ntopology.com.
  • To modify the visibility of the above toolkits and all other tabs in nTop Platform, go to File > Settings > Ribbon and check or uncheck the tab name to change visibility. To modify the order, select the up or down arrows to the right of the tab name in this window.
  • Note: Having an older version of the toolkits installed will not cause any conflicts. If you installed an older version with the separate .msi file, you can safely uninstall them from the Windows Add and Remove Programs section in the windows settings.

New Help Menu

  • The Help menu, which is now represented as an icon, appears to the far right of the user interface and includes the following menu options:
    • About
    • Documentation
    • What’s New
    • Support

New User Profile Menu

  • We’ve introduced a new User Profile menu that links users directly to their online nTopology account at app.ntoplogy.com.
  • If you do not have an nTopology account, please reach out to support@ntopology.com.

Local Licenses on app.ntopology.com

  • We now offer the ability to have your local license hosted on your nTopology account.
  • If you’d like to have an nTopology account at app.ntoplogy.com and would like to have access to your local license through your account, please reach out to support@ntopology.com

New Software Updates Menu

  • We’ve introduced a new software update icon and menu to the far right of the user interface that turns green when a new release is available.
  • When this happens, select the icon to expand the menu and select the option to update to the latest release.
  • Once the download begins, a progress bar will appear indicating the time remaining for the download.
  • You can cancel at any time by selecting the X next to the progress bar.
  • Once the new version has been installed, the Icon will turn grey, indicating that no new release is available at this moment in time.

New Section Cut Functionality

  • We’ve improved our section cut tool to let users cut through multiple objects at once.
  • We’ve introduced x as a shortcut to activate this feature.
  • To cut through individual objects, change the Mode from Global to Selection.
  • To invert the direction of the section cut, select the Flip Normal button beneath the Plane normal parameters.
  • By default, the outline of the display style is set to Outline. You can remove the outline by changing the display style to Shaded.

NewSectionCutFunctionality.png

Usage Improvements

  • Upon solving a Static Analysis, Von Mises Stress Results now appear as the first stress option when the stress overload is selected in the Heads Up Display (HUD).

Toolkit 0.3 Updates

  • General:
    • Toolkits now support block deprecation. Any files that contain older deprecated blocks from a toolkit will continue to load if you update the toolkit to a newer version, and run as they did before.

    • Toolkits will now only show a single instance of a toolkit block in the search even if that block shows up in 2 or more toolkits.

    • Architected Materials Toolkit:

      • Infill Orthofoam Lattice:
        • Now using the new Orthofoam Block, which uses a different algorithm, but has major improvements on speed.
      • Voronoi Bubbles:
        • A new parameter added called Feature size enabling the user to control the underlying mesh feature size of the object. Users can increase this value to improve speed while texturing large scale objects.
    • Lightweighting Toolkit:

      • Shell and Gyroid:
        • Bug Fix: Blend radius now works.
      • Shell and Voronoi:
        • Bug Fix: Blend radius now works.
Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.